This wiki has been migrated to https://gitlab.com/wireshark/wireshark/-/wikis/home and is now deprecated. Please use that site instead.
Differences between revisions 3172 and 3173
Revision 3172 as of 2013-09-20 18:38:59
Size: 6384
Editor: Michael Mann
Comment:
Revision 3173 as of 2013-09-20 18:42:45
Size: 6780
Editor: JeffMorriss
Comment: Add r49673 to the queues for 1.10.3 and 1.8.11 (as requested in bug 8742).
Deletions are marked like this. Additions are marked like this.
Line 14: Line 14:
  * [[http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=49673|Rev 49673]] - [[https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8742|Bug 8742]] - Fix corrupt-netmon crash (part 2)
Line 38: Line 39:
  * [[http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=49673|Rev 49673]] - [[https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8742|Bug 8742]] - Fix corrupt-netmon crash (part 2)

Roadmap

This is a tentative roadmap for the next stable releases of Wireshark. For more information on the Wireshark release lifecycle and on past releases see Development/LifeCycle.

Planning

  • Release

    Expected Date

    Notes

    1.11.0

    Unknown

    Next development release

    1.10.3

    Unknown

    Next maintenance release of the stable branch

    1.8.11

    Unknown

    Next maintenance release of the old stable branch

Upcoming Release Status

1.10.3

Pending Tasks

Completed Tasks

  • Queue Empty

Deferred or Rejected Tasks

  • Rev 51077 - Bug 8995 - Fix configure script to get Python major version correctly if system python is version 3+ -- Didn't apply (copied updated code over by hand)

  • Rev 51236 - Bug 9014 - Crash in TShark with option "-z io,stat" in the presence of negative relative packet timestamps -- Doesn't apply cleanly

1.8.11

Pending Tasks

Completed Tasks

  • Queue Empty

Deferred or Rejected Tasks

  • Rev 51236 - Bug 9014 - Crash in TShark with option "-z io,stat" in the presence of negative relative packet timestamps -- Doesn't apply cleanly

  • Rev 51422 - Bug 8989 - SGI Nsym disambiguation is unconditionally displayed when dissecting VHT -- Doesn't exist in 1.8?

Proposed Changes

  • Items marked with {1} in the TODO list of Development/SNMP

  • Keep plugin API and ABI stable and versioned, so binary plugins will reliably work with more than one Wireshark version (ABI changes can be followed here: Upstream Tracker)

    • Run tools/git-compare-abis.sh in the Git repository right before the release
    • Bump library versions as needed based on Libtool's documentation (don't forget updating debian/wireshark-common.files and debian/wireshark-common.shlibs)

  • Version checking
  • Windows updater
  • Add privilege separation for dissection
  • Add thread/multiprocessor support

... well, maybe all the points mentioned in the WishList!

Unsorted

  • Security improvements (see also: Security)

    • Add privilege separation for POSIX environments (in progress)
    • Add a similar mechanism for the Windows environment
    • Enhance the API to make it easier to write secure code (e.g. add tvb_get_gstring())?
  • Documentation of library API's (e.g. wiretap)

Discussion

Development/Roadmap (last edited 2020-07-03 15:42:04 by GeraldCombs)